MCPforWP

WordPress security, today

The latest core security releases, what to update, and which WordPress and PHP versions no longer get fixes. Refreshed 1 minute ago.

What to do now

Security

WordPress 7.1.4 security release

Fixes a weakness in the upgrade process that can lead to remote code execution during the upgrade window, several stored XSS issues (block markup, Interactivity API, Customizer selective refresh, Categories, Playlist, image and comments pagination blocks), leaking of unpublished Customizer changesets, and Notes readable by users who cannot edit the post. Root certificates were updated after the eMudhra revocation.

Update to WordPress 7.1.4 now; fixes are being backported to older branches down to 4.7.

Source, WP 7.1.4

PHP

Critical PHP security release

The PHP project fixed two critical vulnerabilities that affect any PHP application, not only WordPress. No WordPress update is required. PHP versions before 8.2 no longer receive security updates from the PHP project.

Update PHP on every server now and move sites off PHP 8.1 or older (check Tools → Site Health → Info → Server).

Source, PHP 8.2+

MCP

MCP Adapter 0.7.1 and 0.6.2 security fixes

Session initialization data is now limited to 4 KiB to prevent oversized data from causing repeated database failures; affected clients must reconnect once. In 0.7.1, an ability not exposed through MCP returns ability_not_found instead of ability_not_public_mcp.

Update to MCP Adapter 0.7.1 (or 0.6.2 for Composer users on 0.6.x) and stop matching on ability_not_public_mcp.

Source, MCP Adapter 0.7.1, 0.6.2

Security

WordPress 7.1.3 security and maintenance release

Seven security fixes, including a stored XSS on the Comments admin page, a DoS in WP_Http::make_absolute_url(), a second-order SQL injection in WXR export, Author users able to sticky posts, unauthenticated disclosure of comments on private posts, and forgeable parameters to the {status}_{type} hook.

Update to WordPress 7.1.3 or later (7.1.4 is current).

Source, WP 7.1.3

Security

WordPress 7.1.2 fixes a critical RCE

An unauthenticated attacker could, under certain conditions, make page template resolution include a readable local PHP file outside the active theme, which can lead to remote code execution (CVE-2026-87902).

Update to WordPress 7.1.2 or later immediately.

Source, WP 7.1.2

Security

WordPress 7.1.1 fixes 11 security issues

Fixes include stored XSS in wpautop(), an HTML API set_modifiable_text() comment breakout, authenticated path traversal in the REST Templates controller, Contributor+ arbitrary post overwrite, and comments (including notes) that any logged-in user could reparent.

Update to the latest 7.1.x release.

Source, WP 7.1.1

Core security releases

Versions that get no more fixes

PHP 8.1, 8.0 are past end of life. See all branches and dates.

Plugin vulnerabilities are coming: we are checking the licence of the public feeds first.